TABLE OF INTENTS

INTRODUCTION TO PHOTOSPHERE ................................................................. 5

STARTING PHOTOSPHERE ............................................................................. 5
Adding images to the Photosphere catalog .................................................. 6
Main browser window buttons and commands explained .......................... 7
1. The <Add> button ..................................................................................... 7
2. Sort … ........................................................................................................ 7
3. Info button … ............................................................................................ 8
4. [Folder], [Timeline], [Subject], [Album], [Keyword], and [Owner] …...... 10
Viewing images, the image window, and commands explained .................. 14
1. Name and <Title> and <Cap> buttons ....................................................... 15
2. The <Apply> and <Fit> buttons … ........................................................... 15
3. HDR related buttons … .......................................................................... 17
The View → … menu commands … ............................................................. 17

MANIPULATING CATALOGS ....................................................................... 19
Opening catalogs and switching between catalogs …............................... 19
Adding thumbnails (records) from one catalog to another ....................... 20
Edit menu commands … .......................................................................... 22
The Edit → Find…, or the <apple-F> command……………………………….. 26
Combining Edit commands … ................................................................... 28
Selections of keywords and how they affect browser behavior … .............. 28
The “shadow” catalog…………………………………………………………... 29
Catalogs allowing multiple entries (thumbnails) per image file……………… 30
How to duplicate image entries … ............................................................... 30
How to crop duplicated entries to show details … .................................... 31
Changing a catalog from single to multiple entry or vice versa ……………… 33
Locked catalog … ...................................................................................... 33

HDR CREATION ......................................................................................... 34
HDR example image comparisons … .......................................................... 36
Saving HDR images … ............................................................................ 38
HDR error messages and what do they mean … ........................................ 39
How to shoot bracketed images (taken from the Photosphere Quickstart) – “raw” images not recommended … 40

MAKING A PANORAMA … ......................................................................... 40
RED-EYE REMOVAL … ............................................................................ 40
Exposure Adjustment (SpotMeter) … ......................................................... 41
Image Analysis … .................................................................................... 42

TUTORIAL -- HOW TO MAKE A PANORAMA ........................................ 43
Input images needed for panorama …......................................................... 43

Table of Figures

FIGURE 1. MAIN PHOTOSPHERE BROWSER WINDOW ................................. 5
FIGURE 2. CONFIRMATION DIALOG BOX FOR SINGLE/MULTIPLE ENTRY ….. 6
FIGURE 3. BROWSER WINDOW SHOWING IMAGES THAT HAVE BEEN ADDED TO CATALOG … 7
FIGURE 4. A BAREBONES INFO WINDOW …................................................ 8
FIGURE 5. THE <FILE> TAB OF THE INFORMATION WINDOW ….................. 10
FIGURE 6. BROWSING THUMBNAILS BY [TIMELINE], TWO ENTRIES FOR IMAGES SHARING SUBJECT NAME BUT SEPARATED BY TWO+ DAYS; (XXXXX DON’T LIKE THIS IMAGE, MAKE ANOTHER ONE) … 11
FIGURE 7. BROWSING THUMBNAILS BY [TIMELINE], 24 OF 90 TOTAL RECORDS IN THE CATALOG ARE FROM YEAR 2005 ………………… 12
FIGURE 8. BROWSING THUMBNAILS BY [KEYWORD] “SUNSET” ……………… 13
FIGURE 9. SELECTING THUMBNAILS BY USING [KEYWORD] …………………. 14
FIGURE 10. IMAGE WINDOW ….................................................................. 15
FIGURE 11. A rectangle drawn on an image (in the sun spot), followed by a click on the
<APPLY> button.........................................................16
FIGURE 12. The view menu as seen from main browser window.........................................17
FIGURE 13. Photosphere browser window when the thumbnail view is unchecked. ............18
FIGURE 14. The view menu as seen from the image window, with the thumbnail display option
grayed out.........................................................18
FIGURE 15. Histograms.........................................................19
FIGURE 16. Falsecolor display.........................................................19
FIGURE 17. Switching between catalogs (first catalog).........................................................20
FIGURE 19. Switching between catalogs (second catalog). Add images by selecting them and
clicking the <ADD> button.........................................................21
FIGURE 20. The Edit → Copy command and the Edit → Cut command. .................................23
FIGURE 22. The Edit → Paste command.........................................................23
FIGURE 21. The browser window is refreshed by double clicking on the album name........24
FIGURE 25. The Edit → Clear command. Selected thumbnails “cleared” from display........24
FIGURE 24. The Edit → Clear inverse command, left. Selected thumbnails kept in display with
the “clear inverse” command while non-selected thumbnails have been removed. Album
images restored after clicking on highlighted subject name, right..........................25
FIGURE 26. The Edit → Delete command and confirmation window.................................25
FIGURE 28. The Edit → Select inverse command toggles the selection of thumbnails...........26
FIGURE 30. A sample catalog with 4 images.........................................................26
FIGURE 31. The Edit → Find … window .........................................................27
FIGURE 32. The difference between using <Search>, left; and <Select>, right...................28
FIGURE 33. The preferences dialog box.........................................................30
FIGURE 34. Confirmation window (need a better caption).....................................................30
FIGURE 35. Duplicating image within the same catalog.....................................................31
FIGURE 36. Image duplicated four times, each renamed..................................................31
FIGURE 37. Original image and its duplicates that have been cropped to show details........32
FIGURE 38. Image browser displaying cropped images (top two panels).........................32
FIGURE 39. Image browser displaying cropped images (top two panels).........................33
FIGURE 40. When “File → Switch Catalog → New …” is selected and an existing catalog name
is selected, .........................................................33
FIGURE 41. Bracketed images are selected in preparation for making HDR.........................34
FIGURE 38. The “Make High Dynamic Range” image dialog box. (The camera make/model
updates automatically).........................................................35
FIGURE 39. Input images unaligned (left), aligned (right)....................................................36
FIGURE 40. Close up of pedestrians on the ground level, ghosts present (top), ghost removed
(bottom).........................................................36
FIGURE 46. Another example set, for reducing flare.........................................................37
FIGURE 43. Close up of HDR image, flare present (left), flare reduced (right)....................38
FIGURE 44. The “Save Options” of the HDR image window................................................38
FIGURE 46. HDR error message – camera response error message....................................39
FIGURE 47. HDR error message – Image capture times too far apart...............................40
FIGURE 48. HDR error message – Images from different cameras or of varying resolution......40
FIGURE 49. Image with red-eye (left), and red-eye removed (right)....................................41
FIGURE 50. SpotMeter applied to dark shade trees......................................................41
FIGURE 51. SpotMeter applied to bright windows.........................................................42
FIGURE 1. Six thumbnails and their features selected for the panorama command...............44
FIGURE 2. First two images of the panorama, “Pano Orig” left and “Pano Dest” right........45
FIGURE 3. 2nd and 3rd images of the panorama, “Pano Orig” left and “Pano Dest” right....45
FIGURE 4. The Make Panorama dialog box.................................................................46
FIGURE 5. Black matte only .......................................................................................47
FIGURE 6. Black matte + Expand ..................................................................................47
FIGURE 7. Black matte + Trim ......................................................................................47
FIGURE 8. Black matte + Expand + Trim ........................................................................47
FIGURE 9. BLACK MATTE + EXPAND + FILL ....................................................................................................... 47
FIGURE 10. BLACK MATTE + EXPAND + TRIM + FILL ................................................................................... 47
FIGURE 11. AVERAGE MATTE + FILL .................................................................................................................. 48
FIGURE 12. AVERAGE MATTE + FILL (CLOSE UP) .......................................................................................... 48
Introduction to Photosphere

This section describes the browsing and image viewing capabilities of Photosphere and covers the basic commands (and buttons) of the main Photosphere browser window, the information window, and the image window. The more complicated commands have their own sections and/or tutorials in other parts of this Document.

Starting Photosphere

The first time you open Photosphere, you will be in the main browser window, Figure 1. At this point you should go ahead and create a new catalog (a new database) by going to File → Switch Catalog → New... and inputting a name when prompted. Photosphere then asks if you want to “allow at most one catalog entry for each file”. File in this case means image. See Figure 2.

Having a single entry for each file means there can be only one record of your image within this particular catalog.

Having multiple entries for each file means that you can have multiple records of your image within this particular catalog. An example of how this can be useful if there is an image that you want to crop in different ways and you want to associate all of the new views that are created with the original image. Single entry is the default and probably sufficient for most users. You will be asked this question once for each new catalog you create (how to change this selection after you’ve made it will be discussed in section xxxx).

Figure 1. Main Photosphere browser window

If this is not the first time you are using Photosphere, then the main browser window opens with the last opened catalog showing, which you can change via the File → Switch Catalog menu item.

Figure 1 shows the main window of Photosphere. Home directory, removable media devices, etc. are listed in the left column and clicking on the “>” expands to show the directories and
subdirectories. Directories containing recognized image formats are shown with their names preceded by a ‘*’.

Photosphere currently supports the following file formats: BMP, EXR, HDR (Radiance high dynamic range format), JPEG, and TIFF.

Adding images to the Photosphere catalog

The following two steps will add images to the Photosphere catalog.

1. Make sure the [Folder] tab is highlighted and directories are listed in the lefthand column. Double click on the desired image directory to begin scanning, and all compatible images in that directory will be displayed as thumbnails on the right. Alternatively, you can use File → Open Directory….

2. Select the image(s) that you want to save to the catalog and click the <Add> button. You will then be prompted to enter a subject name for the image(s). Every image that goes into the catalog must have a subject (and only one subject), the default being the image folder name. Repeat this process for other directory locations as needed.

Similar to other programs, multiple images can be selected at once by using <shift-click> and <apple-click>.

Note that if you want to remove an image from the catalog (but delete it from the hard drive), select it and press <apple-x>, or go to Edit → Cut.

For more information, please refer to section XXXXX which covers the six vertical Photosphere browser window tabs: [Folder], [Timeline], [Subject], [Album], [Keyword], and [Owner].

Once added to the catalog, the thumbnail drop shadow changes from blue to green. Note that a red drop shadow means read-only, indicating the image is in a locked catalog.

Figure 3 shows a catalog which has several subjects, and thumbnails of images from “gregs_camera” are displayed on the right.

If any of the thumbnails need to be rotated at this time, they can be selected and rotated en masse with the shortcut <apple-R> for clockwise rotation, <apple-L> for counter clockwise rotation, or by going to View → Reorient →….
Main browser window buttons and commands explained

The numbered headings below correspond to the dashed and numbered boxes in Figure 3 above.

1. The <Add> button

The <Add> button is only used for adding images to catalogs. Edits to non-cataloged images will not be saved in your catalog but in the “shadow catalog”. For more information about the shadow catalog, please see section xxxxxx (appendix?).

The text below the <Add> button means different things depending on the most recent command. It could be reporting how many thumbnails are highlighted, how many are in the catalog, or how many records have been changed.

Sidebar:

Note that with the exception of <delete> and <rename>, commands within Photosphere do not affect the original images. Edits such as rotating and cropping are displayed only in the catalog but have no affect on the originals unless you explicitly overwrite them.

However, deleting images permanently removes them from both the catalog and your harddrive (and no copy in the trash), and renaming files cannot be undone except by manually renaming them again.

2. Sort…

The thumbnails can be sorted by any of the criteria listed. The criteria are mostly self-explanatory, with “hand” meaning manual sorting.

When the <Reverse> box is checked, the display order of the thumbnails is reversed, for example, reverse sorting by date.
3. Info button

When one or more thumbnails have been selected, the <Info> button can be clicked to bring up the information window shown in Figure 4. (A simplified version of this window can be accessed by <option-click> or <control-click> on a thumbnail).

The current thumbnail image is identified in the information window; clicking on the up/down buttons scrolls through all of the selected thumbnails.

![Info window](image.png)

**Figure 4. A barebones Info window**

<table>
<thead>
<tr>
<th>Field</th>
<th>Purpose</th>
<th>Uses</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subject</td>
<td>image inventory</td>
<td>searching, event timeline</td>
<td>required field, one assignment</td>
</tr>
<tr>
<td>Keyword</td>
<td>image associations</td>
<td>searching</td>
<td>multiple assignments</td>
</tr>
<tr>
<td></td>
<td>(people, etc)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Owner</td>
<td>image creator</td>
<td>searching</td>
<td>optional, one assignment</td>
</tr>
<tr>
<td>Title</td>
<td>name for image</td>
<td>browser display, album</td>
<td>optional, one assignment</td>
</tr>
<tr>
<td>Comment</td>
<td>reminder</td>
<td>anything not fitting the above list</td>
<td>multiple assignments</td>
</tr>
<tr>
<td>Album</td>
<td>organizing, exporting, printing</td>
<td>webpage, printed album, sorted list</td>
<td>multiple assignments</td>
</tr>
<tr>
<td>Caption</td>
<td>subtext association with image in album</td>
<td>webpage, printing</td>
<td>optional, one assignment per album per image</td>
</tr>
</tbody>
</table>

**Table 1. List of user fields available for image records**
Directions for filling in the fields in the <settings> tab of the information window:

Input into a field and press <enter> to save the changes. The <tab> key jumps between fields but does not save your inputs. The arrow keys next to the file name changes images.

An image can have only one subject, one title, and one owner. Subject is mandatory, the other two are not. If a title is set, it will be displayed in place of the filename for the thumbnails.

It can have multiple keywords entered separately (separated by pressing <enter>) and multiple comments.

To erase information in a field, <delete> what is shown in the field and press <enter>. Alternatively, go to Set → … and uncheck the undesired box.

The Album field cannot be filled out from here; it has to be assigned from the browser window through the Set → Album command, to be discussed in section xxxxx.

The <Caption> field will only be activated when the image is associated with an Album (the caption is printed with the images when you print an Album).

Note that activating the information window and inputting for each image manually is usually not the most efficient method of populating these fields. A better and faster way is to use the Set → … command, to be explained in section xxxxx

Clicking the <Open> button on the <Settings> tab opens up an image window, such as Figure 10, and displays the image.

The information fields under <File> and <Origin> are uneditable through this interface and, depending on the image origin, may be unavailable. If the image is a panoramic or high dynamic range (HDR) image, then the images used for the composition will be listed in the history field under <File>, see example in Figure 5.

The <Other> tab displays custom information. It is unless one or more custom fields are created through the Set → Other → Field… command, refer to section xxxxx for information on creating custom fields.

The <Preview> tab shows an enlarged thumbnail image.
4. [Folder], [Timeline], [Subject], [Album], [Keyword], and [Owner]

The six vertical tabs in the Photosphere main browser window offer different ways for browsing, organizing, and viewing images. With the exception of the [Folder] and [Timeline] tabs, they can be modified by going through the settings tab of the information window, Figure 4, or by the using the set command.

The [Folder] tab is what you should use when browsing for new images to add to the catalog; the others are not applicable to images until they have been added to the catalog and have been assigned by you. [Folder] is also the only one which causes Photosphere to scan directories for new images and thus will take longer to display the thumbnails compared to the other headings (which pull up stored entries/records from the catalog).

The [Timeline] tab organizes the catalog images first by year, then by month, then by subject. If images with the same subject are timestamped within a span of two days, for example June 30th and July 1st, then Photosphere will record them under the month of June. Another example would be images from December 30th 2005 and January 1st 2006 – these would be cataloged under year 2005 and December.

This organization process is based on the assumption that images with the same subject less than 2 days apart were from the same “event” and that when you search for them (for this event), you would most likely want to see all of the associated images displayed at the same time.

Conversely, if images have the same subject but are separated by more than two days, they will have separate entries in the timeline because Photosphere assumes they are from different “events”. See August in Figure 6.

A single click on the “>” expands the selected timeframe, and a single click on the year/month or subject highlights the selected thumbnails on the right and updates the line of text under the <Add> button. That line tells you how many images in the whole catalog fall within the selected timeframe or subject.
A double click on the year/month or subject updates the thumbnails to show only those which fall within the selected timeframe or subject, and the text under the <Add> button will change again, see Figure 7.

A double click on a month or year, or multiple events, shows all images in the catalog that match the selected (range of) events.

Figure 6. Browsing thumbnails by [Timeline], two entries for images sharing subject name but separated by two+ days. (xxxxx don’t like this image, make another one)
It is best to have the correct date and time set on your camera before you start photographing so that [Timeline] can organize the images properly. **There is a command which can help adjust the dates, please see section xxxxx.**

The [Subject] tab organizes your images according to subject. Each image must have one and only one subject. If you want to change the subject after it has been assigned, you can do so through the information window (Figure 4) or through the Set → Subject command. The current subject is checked; you can either select another from the list or create a new one through the Set → Subject → Other... field.

The [Album] tab organizes your images for printing and web export. An image can belong to multiple albums and have different captions in the different albums. To assign images to an album, select the desired thumbnails and then go to Set → Album...

An image can only be captioned after it is associated with an album (because the caption is meant to be printed with the album). To caption, go to Set → Caption. Alternatively, bring up the information window (Figure 4), select the <Settings> tab, type in the caption field, and press <enter> to save.

Note that if an image belongs to multiple albums, you can input different captions by utilizing the latter method and toggle between albums by the up/down arrows next to the <Caption> button.

The [Keyword] tab organizes your images according to keywords. Images can have multiple keywords or none at all. You can select multiple images at once by using the <apple-click> and <shift-click>, then assigning the keyword by going to Set → Keyword.

When you double-click on a keyword while in the browser window, the images associated with that keyword will be displayed on the righthand side, see Figure 8 below. To select multiple keywords, use the <apple-click> or <shift-click> method.
Figure 8. Browsing thumbnails by [Keyword] “sunset”

A single click on another keyword at this time causes images which have either as keywords to be highlighted. Figure 9 shows the thumbnail of an image which has both “sunset” and “panorama” as keywords highlighted. Every time you single click on a keyword again, the browser will display those images which have both the original and latest keyword (the intermediarily selected keywords are ignored) REWORD.
The [Owner] tab organizes your images according to ownership. An image cannot have multiple owners, but it can be ownerless.

**Viewing images, the image window, and commands explained**
While it is possible to view images after only step 1 in section XXXXX (without first adding them to the catalog), it is best to add them to a catalog if you plan on modifying the images and so you can include them in searches. Double clicking on a thumbnail or multiple thumbnails brings up the image window, see Figure 10.
Figure 10. Image window.

The numbered boxes in Figure 10 correspond to:

1. **Name and <Title> and <Cap> buttons**
   The name of the image is displayed in the upper lefthand corner. You can use the up/down arrow buttons to manually cycle through images if more than one has been opened.
   The <Title> and <Cap> (short for Caption) buttons share the field immediately to their right. When the <Title> button is blue, you can type into the field and press <enter> or click on the <Title> button to save your entry as the title. If the image has already been associated with an album, then the same can be done with the <Cap> button to create a caption.

2. **The <Apply> and <Fit> buttons**
   You may encounter a set of up/down buttons next to the <Apply> button, please see sidebar.
   The <Apply> button becomes active after you draw a rectangle on the image with the mouse button clicked down. A click on an activated <Apply> button brings up a list of commands. Depending on the size of the rectangle and the type of image you are viewing, you may see a list similar to the one shown in Figure 11.

Sidebar: According to Greg:
Funny little buttons, aren’t they? Some TIFF and Radiance files can have multiple images stored in them, and these arrows go between frames. Sometimes, Photosphere doesn’t know for sure if a file has multiple images until it goes to look for them, which is a bit expensive, so the little arrows may appear until you click on them, then they vanish. Very mysterious, I’m afraid! **GREG says change.**
Sidebar:

<Crop> cuts out everything that is outside of the rectangle. Whatever is inside the rectangle will remain. (Again, this only affects how it is displayed in the Photosphere catalog and does not affect the original image, and an image may be “uncropped” to show the full, original image at any time.)

<RedEye> means red eye reduction (It’s not applicable for the above example). You should be selecting as small as an area as possible for this command. If the eye is not REALLY red, this command will ignore it. **REWORD**

<SpotMeter> means re-exposing the image based upon the average luminance (or brightness) of the pixels within the rectangle.

<Pano Orig> is short for “panorama origin point”, and appears on the list only when the rectangle drawn is small. This is the first step towards making a panorama from your images. For details, please refer to the [panorama tutorial](#).

<Calibration> appears on the list only when you are viewing a HDR image. You can use this command to calibrate the luminance values. If the selected area is large, the command will not be available. **Expand explantion.**

Each of these commands can be undone by going to Edit → Undo…, or using the associated reverse Apply menu item when no rectangle is selected.

The <Fit> button is how the image is displayed within the image window. <Fit> is the default view; all the available options are listed in the pull down list as you click on the button.
3. HDR related buttons

Note that the following options are only applicable to HDR images and affect how they are displayed. For non HDR images, the buttons will appear grayed out.

<Exp> is short for exposure, and the up/down arrows next to it adjust the exposure of the displayed image. When the <Auto> box is checked, the tone-mapping is adjusted based on the luminance histogram. The “Local” check box ...

When the image window first opens, the line of text below the exposure information shows the image creation date and time. If you click anywhere on the image, the text changes to show luminance (cd/m²) followed by cursor location. Note that the origin (0,0) position varies depending on whether the image has been rotated or not. If a rectangle is drawn on the image instead of a click, the luminance value shown is the average of all the included pixels.

The View → … menu commands

Figure 12. The View menu as seen from main browser window.

The View →… menu contains commands which affect how you see your images and thumbnails.

After you have selected multiple images, you can click on View → Slide Show to display them automatically.

The next three commands, View → Sync View, Histogram, and False Color are only activated when viewing an image in the image browser, please see section xxxxx.

Reorient rotates the images.

The rest of the View menu commands all relate to how the images and their information are displayed. They affect different things depending on whether the browser or image window is in the foreground. Probably the most typical views will involve looking at thumbnails of varying sizes -- preview, large, medium, or small – with preview being the largest. You can also use the shortcut keys <option-[]> and <option-[]> to enlarge and reduce the thumbnails, respectively. The
thumbnails revert to a list view if you uncheck the thumbnail option (or if you keep pressing <option->), see Figure 13.

![PhotoSphere browser window when the thumbnail view is unchecked.](image1)

Figure 13. Photosphere browser window when the thumbnail view is unchecked.

The View → Settings, File, Origin, and Other, affect what information is displayed in place of the thumbnails. These four options correspond to the information window tabs shown in Figure 4. View → Show All means show all data.

<Actual Size> Greg, I have a problem with this. Actual size is the same as preview size when in the browser window, so why do you need both?

![View menu as seen from the image window, with the thumbnail display option grayed out.](image2)

Figure 14. The View menu as seen from the image window, with the thumbnail display option grayed out.

View → Sync View maintains the zoom, position, selection and exposure from one image to the next. This is useful for doing comparisons of multiple images. REWORD

<Histogram> shows histograms of luminance and red, green, and blue, see Figure 15.
The <False Color> command applies to HDR images only. It displays the image in falsecolor and an accompanying scale (log scale when displaying luminance).

**Manipulating catalogs**

The steps for how to create a new Photosphere catalog are described in section xxxxx. The following sections will cover how to manipulate catalogs (excluding the import/export and printing commands, which will be covered in section xxxxx later).

**Opening catalogs and switching between catalogs**

Only one catalog may be open at any given time. You can switch between catalogs by going to File → Switch Catalog, see Figure 17. Selecting “New...” means creating a new catalog, while “Other...” means you are looking for a catalog that is not in the recently opened list.
Note that you do not need to save a catalog before you open another since changes are always automatically saved, and Photosphere always begins with the last accessed catalog open.

Figure 17. Switching between catalogs (first catalog)

Adding thumbnails (records) from one catalog to another

It is possible to copy records from one catalog as you are switching between catalogs. In the previous figure, the existing catalog is called “gregpics” and thumbnails with the keyword “sunset” are displayed in the browser window. In the following figure, the second catalog, “judypics”, is opened and while the list of keywords is updated, the sunset thumbnails from “gregpics” remain. This overlap makes it possible for the “sunset” thumbnails to be selected and added to the second catalog. Note that all of the associated information, e.g., keywords, subject, comments, etc., will be added into the catalog.
Figure 18. Switching between catalogs (second catalog). Add images by selecting them and clicking the <Add> button.

Another way to copy from one catalog to another is to select the images that you want to copy, goto Edit → Copy… to save them temporarily to the clipboard, then use File → Switch Catalog... to switch to another catalog, and then click the <Add> button.
## Edit menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Purpose</th>
<th>Comments</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo…</td>
<td>undoes the previous command</td>
<td>undo possible back to the first command of open session</td>
<td>NA</td>
</tr>
<tr>
<td>Can’t</td>
<td>informs user that the last command cannot be</td>
<td>graying out in the menu, not a selectable command</td>
<td>NA</td>
</tr>
<tr>
<td>Undo</td>
<td>undone</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo…</td>
<td>undoes the “undo” command</td>
<td>does not redo the previous command unless the previous command was</td>
<td>NA</td>
</tr>
<tr>
<td></td>
<td></td>
<td>“undo”</td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>removes the selected image(s) from catalog and</td>
<td>does not permanently delete the image(s) from hard drive, can be undone</td>
<td>Figure 19</td>
</tr>
<tr>
<td></td>
<td>onto clipboard</td>
<td></td>
<td>(right)</td>
</tr>
<tr>
<td>Copy</td>
<td>copies the selected image(s) to clipboard</td>
<td>also copies related information</td>
<td>Figure 19</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(subject, keyword, owner, etc)</td>
<td>(left)</td>
</tr>
<tr>
<td>Copy</td>
<td>copies the filename(s) including directory paths</td>
<td>useful for figuring out where the images are located and copying into</td>
<td>NA</td>
</tr>
<tr>
<td>Filenames</td>
<td></td>
<td>other programs</td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td>pastes in the copied image(s)</td>
<td>refer to longer explanation below example images</td>
<td>Figure 20</td>
</tr>
<tr>
<td>Duplicate</td>
<td>makes copy of selected image(s) in the same</td>
<td>applicable only for catalogs that allow for multiple image entries</td>
<td></td>
</tr>
<tr>
<td></td>
<td>catalog</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Clear</td>
<td>temporarily removes selected thumbnail(s) from</td>
<td>does not affect catalog; double click on the subject/keyword/etc to</td>
<td>Figure 22,</td>
</tr>
<tr>
<td></td>
<td>display window</td>
<td>restore thumbnail(s) to display</td>
<td>Figure 21</td>
</tr>
<tr>
<td>Clear</td>
<td>temporarily removes the not selected thumbnail(s)</td>
<td>see above</td>
<td>Figure 23,</td>
</tr>
<tr>
<td>Inverse</td>
<td>from display window</td>
<td></td>
<td>Figure 21</td>
</tr>
<tr>
<td>Delete</td>
<td>deletes selected image(s) from catalog AND hard</td>
<td>command CANNOT be undone, irretrievable from the trash, asks for</td>
<td>Figure 24</td>
</tr>
<tr>
<td></td>
<td>drive permanently</td>
<td>confirmation</td>
<td></td>
</tr>
<tr>
<td>Select All</td>
<td>selects all currently displayed thumbnails</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select None</td>
<td>deselects all thumbnails</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select Inverse</td>
<td>toggles the selection</td>
<td></td>
<td>Figure 25</td>
</tr>
<tr>
<td>Find…</td>
<td>opens a search window</td>
<td>refer to longer explanation below example images</td>
<td>Figure 26</td>
</tr>
</tbody>
</table>

**Table 2. Table of Edit commands**
The previously copied and cut image is shown in the left image right after pasting. The image has a blue drop shadow (image enlarged to show detail), which means it is not part of the catalog. The image on the right shows the pasted image after the <Add> button has been clicked and the image added back to the catalog.
Figure 21. The browser window is refreshed by double clicking on the Album name

Figure 22. The Edit → Clear command. Selected thumbnails “cleared” from display
Figure 23. The Edit → Clear inverse command, left. Selected thumbnails kept in display with the “clear inverse” command while non-selected thumbnails have been removed. Album images restored after clicking on highlighted subject name, right.

Figure 24. The Edit → Delete command and confirmation window
The Edit → Select inverse command toggles the selection of thumbnails

**The Edit → Find…, or the <apple-F> command**

Through the Edit → Find command, it is possible to manipulate the catalog and have it display only the thumbnails that satisfy certain criteria. Below is the same sample catalog with four images. An explanation of the find command window, Figure 27, follows.

**Figure 26. A sample catalog with 4 images**
Proceed in order of the numbered circles above. For this example,
Click on button #1 to see all of the possible search parameters.
Click on button #2 to toggle amongst the three choices for the search parameter – is, is between, and contains. “Is” looks for an exact match. “Is between”, when clicked, will open another line so you can fill in two values (most obvious choice to use when specifying a range of dates to match). “Contains” matches fields containing a word or phrase.
Click on button #3, the list button, to display all of the possible values for field #4 if you are unsure of what the input should be.
You can click on button #10 <Search> once field #4 has been filled out.
Assuming a search for keyword “animal”, the resulting catalog would look like Figure 28, left.

Note:
This example of a search for a keyword is more for the purpose of showing the process and results of this kind of search rather than for practicality (since a keyword search can be much more easily performed directly within the main browser window by clicking on the desired keyword). A more realistic search in this instance would have the command look for something that is not easily performed by you, e.g., look for images shot with a certain ASA and/or having x-second exposure time, and/or in JPEG format, etc.
Searches are not case sensitive.
If you want to have two search criteria, then click on button #5 to toggle your choices – “AND”, and “OR” (the first position of the button is a blank space, select it when you only want to input one search field).
Buttons #6 through #9 operate in the same manner as those from #1 through #4. If using the operator “AND”, then only images which satisfy both criteria will be shown in the browser window; the rest will temporarily be cleared from the display.
<Select> is similar to <Search>, but will highlight only those images that meet your criteria in the current set of browser thumbnails, see Figure 28 right.
Combining Edit commands

The `<Select>` command under Edit → Find… can be combined with the clear, clear inverse, and select inverse commands of the Edit menu. Table 3 below explains what results when the commands are combined.

<table>
<thead>
<tr>
<th>Edit → Find … <code>&lt;select&gt;</code></th>
<th>Edit → Clear</th>
<th>Edit → Clear Inverse</th>
<th>Edit → Select Inverse</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field 1 + X</td>
<td></td>
<td></td>
<td></td>
<td>Images matching field cleared from display</td>
</tr>
<tr>
<td>Field 1 +</td>
<td></td>
<td>X</td>
<td></td>
<td>Images NOT matching field cleared from display</td>
</tr>
<tr>
<td>Field 1 +</td>
<td></td>
<td></td>
<td>X</td>
<td>Images NOT matching field are selected in the display</td>
</tr>
<tr>
<td>Field 1 and Field 2 +</td>
<td></td>
<td>X</td>
<td></td>
<td>Images matching both fields cleared from display</td>
</tr>
<tr>
<td>Field 1 and Field 2 +</td>
<td></td>
<td></td>
<td>X</td>
<td>Images NOT matching both fields cleared from display</td>
</tr>
<tr>
<td>Field 1 and Field 2 +</td>
<td></td>
<td></td>
<td>X</td>
<td>Images NOT matching both fields are selected in the display</td>
</tr>
<tr>
<td>Field 1 or Field 2 +</td>
<td></td>
<td>X</td>
<td></td>
<td>Images matching either fields cleared from display</td>
</tr>
<tr>
<td>Field 1 or Field 2 +</td>
<td></td>
<td></td>
<td>X</td>
<td>Images NOT matching either fields cleared from display</td>
</tr>
<tr>
<td>Field 1 or Field 2 +</td>
<td></td>
<td></td>
<td>X</td>
<td>Images NOT matching either fields are selected in the display</td>
</tr>
</tbody>
</table>

Table 3. Need a good caption here.

Selections of keywords and how they affect browser behavior
<table>
<thead>
<tr>
<th>Keyword 1</th>
<th>Keyword 2</th>
<th>Cut or Clear</th>
<th>Clear Inverse</th>
<th>Select Inverse</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single click</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>keyword 1 images highlighted in display</td>
</tr>
<tr>
<td>Single Click</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td>keyword 1 images cleared from display</td>
</tr>
<tr>
<td>Single click</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td>non-keyword 1 images cleared from display</td>
</tr>
<tr>
<td>Single click</td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td>non-keyword 1 images highlighted in display</td>
</tr>
<tr>
<td>Single click</td>
<td>single click</td>
<td></td>
<td></td>
<td></td>
<td>keyword 2 images highlighted in display</td>
</tr>
<tr>
<td>Double click</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>non-keyword 1 images cleared from display</td>
</tr>
<tr>
<td>Double click</td>
<td>double click</td>
<td></td>
<td></td>
<td></td>
<td>non-keyword 2 images cleared from display</td>
</tr>
<tr>
<td>Double click</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>non-keyword 1 images cleared from display</td>
</tr>
</tbody>
</table>

Table 4. Insert Table caption.

The “shadow” catalog
You can browse, rotate, crop, etc. images that are not saved into a catalog (see section xxxxx), but you cannot assign subjects, keywords, etc. to them for searching or sorting purposes. The changes you make to these non-cataloged images are tracked in what is called the “shadow” catalog. You can find out the location of the shadow catalog (and also the log file and the thumbnail cache) by going to Photosphere → Preferences …, see Figure 29.

An added benefit of the shadow catalog is that it keeps track of changes that
Figure 29. The preferences dialog box

Catalogs allowing multiple entries (thumbnails) per image file
Photosphere asks the following question, Figure 30, whenever you start a new catalog.

Figure 30. Confirmation window (need a better caption)

If you click on <Multiple>, you will have the option of having multiple (duplicate) records/entries for each image within the same catalog. This is useful for images that you want to crop in different ways to highlight details.

How to duplicate image entries
Select the image (or images) to be duplicated and goto Edit → Duplicate. The duplicated thumbnail will be displayed by itself in the browser window and the title or file name will now read “Copy of…”, see Figure 31. The copy is not yet added to the catalog; to do so, click on the <Add> button.

Note that if you want to duplicate an image’s record more than once, you will need to make sure that the duplicates’ titles are different or else Photosphere will not be able to distinguish between the copies. The title change is automated if you duplicate the “Copy of…” image instead of the original (the new image will be named “Copy of Copy of…”). Figure 32 shows the same image duplicated four times and with the titles changed and shortened (by going through the Info button, the Set → Title…, or the <option-T> command.)
Figure 31. Duplicating image within the same catalog

Figure 32. Image duplicated four times, each renamed

How to crop duplicated entries to show details
Figure 33. Original image and its duplicates that have been cropped to show details.

Figure 34. Image browser displaying cropped images (top two panels).
Changing a catalog from single to multiple entry or vice versa

If you change your mind after you have selected a format, you can modify the format by following these steps.

Have open in the browser window the catalog that you want to change from single to multiple or vice versa.

Goto File → Switch Catalog → New… and go to the location of the currently open catalog. It should be grayed out and appear to be unavailable for selection.

In that same location, NAME THE STEPS…

Locked catalog

If for some reason Photosphere shuts down unexpectedly, then the next time it starts up, it could be in “read only” mode. If this is the case, all of the thumbnails will have red drop shadows instead of green or blue, and you will be able to browse images but not make any changes to the catalog until the corresponding .lck file is removed. The .lck file is always located in the same directory as the catalog file, and should be deleted when the catalog is closed.

Photosphere Documentation
Section C – Advanced Features
not covered here: image analysis
**HDR Creation**

To create a high dynamic-range image using Photosphere, there must be a set of images with "bracketed" exposures of a static scene, and they should not have been processed with any other program (e.g., Photoshop) prior to being passed to Photosphere. (For information on how to shoot a set of bracketed images, refer to XXXXX).

Select the thumbnails of the images that you would like to use to create the HDR image, Figure 37 or Figure 41, then goto File → Make HDR to bring up the “Make High Dynamic Range” image dialog box, Figure 38.

![Figure 37. Bracketed images are selected in preparation for making HDR.](image-url)
There are several options to select from for making the HDR image. If you are uncertain of which boxes to check, refer to Table 5 below for information on the options. The more “passes” an option needs, the longer it will take to generate the image. Some options may cause artifacts.

<table>
<thead>
<tr>
<th>Option</th>
<th>Have Photosphere…</th>
<th>Passes</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Saved Response</td>
<td>use a previously saved computed response function of the same camera. The response functions are saved in user/Library/Preferences/Photosphere, and are separated by camera make, model, and firmware version.</td>
<td>NA</td>
<td>Figure 42</td>
</tr>
<tr>
<td>Save New Response</td>
<td>record the computed response function for the camera and save into its preferences file, which will save time and reduce error in subsequent HDR images.</td>
<td>min 2 passes</td>
<td>NA</td>
</tr>
<tr>
<td>Remove Lens Flare</td>
<td>minimize the artifacts of stray light and lens flare.</td>
<td>extra pass</td>
<td>Figure 39</td>
</tr>
<tr>
<td>Remove Ghosts</td>
<td>minimize the artifacts of objects (people, cars, etc) moving between the different exposures/images. May cause artifacts.</td>
<td>extra pass</td>
<td>Figure 40</td>
</tr>
<tr>
<td>Align Images</td>
<td>minimize the artifacts caused by camera movements between exposures/images. Box can be unchecked if camera was mounted on a tripod during image capture.</td>
<td>min 2 passes</td>
<td>Figure 39</td>
</tr>
<tr>
<td>Fine-tune Exposures</td>
<td>improve the accuracy of HDR combinations. It does not have a big, visible effect on the results, but may give better relative accuracy in photometric applications with cameras that do not record their exposure settings precisely.</td>
<td>min 2 passes</td>
<td>NA</td>
</tr>
<tr>
<td>Skip Extra Exposures</td>
<td>ignore those images which do not contribute useful luminance information.</td>
<td>NA</td>
<td></td>
</tr>
</tbody>
</table>

Table 5. Options of the “Make High Dynamic Range” image dialog box.

The HDR building process will take a few minutes; the more megapixels there are in the image, the longer this process takes. Once an HDR image has been computed, it is stored as a...
temporary file in 96-bit floating-point TIFF format and displayed in a new image browser. Note that a newly created HDR image is not automatically added to the catalog.

**HDR example image comparisons**

**Figure 39.** Input images unaligned (left), aligned (right).

**Figure 40.** Close up of pedestrians on the ground level. Ghosts present (top), ghost removed (bottom).
Figure 41. Another example set, for reducing flare.
Figure 42. Close up of HDR image. Flare present (left), flare reduced (right).

**artifacts – can get black areas**?

**Saving HDR images**

When you are satisfied with your HDR images, you can save it by going to File → Save As..., Figure 43.

![Save Options](image)

**Figure 43.** The “Save Options” of the HDR image window.
The “Save in high dynamic range” checkbox together with the “Compression Quality” slider bar affect the file format options. The other three checkboxes are options that may or may not be selectable, depending on what has been done to the image, see explanation in Table 7.

For JPEG-HDR, it controls the quality setting of the output between a value of 45 (Fair) and 100 (Best). For Radiance RGBE, a setting of “Best” stores uncompressed (flat) files, and anything lower stores a standard run-length encoded file. For TIFF, a setting of “Best” stores 32-bit/channel IEEE float data. A “Fair” setting produces a 24-bit/pixel LogLuv file, where anything else stores 32-bit/pixel LogLuv. (16-bit/channel data is only supported by TIFF, and is not affected by the quality slider.) The slider doesn’t affect OpenEXR output at this point. Make the text and the table consistent.

<table>
<thead>
<tr>
<th>Save Options</th>
<th>File formats available</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save in HDR + slider bar all the way to the right of “Best”</td>
<td>96-bit TIFF, Radiance, OpenEXR, and JPEG-HDR.</td>
</tr>
<tr>
<td>Save in HDR + slider bar between “Good” and “Best”</td>
<td>32-bit LogLuv TIFF, Radiance, OpenEXR, and JPEG-HDR</td>
</tr>
<tr>
<td>Save in HDR + slider bar between “Fair” and “Good”</td>
<td>24-bit LogLuv TIFF, Radiance, OpenEXR, and JPEG-HDR</td>
</tr>
<tr>
<td>Save in HDR unchecked … More here</td>
<td>24-bit TIFF and standard JPG.</td>
</tr>
</tbody>
</table>

Table 6. Save options of the HDR image window

<table>
<thead>
<tr>
<th>Save Checkboxes</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply orientation &amp; cropping</td>
<td>If rotation, cropping, and/or red-eye reduction had been performed, the resulting image is saved instead of the original. (recommended)</td>
</tr>
<tr>
<td>Apply zoom (re-sample)</td>
<td>Saves the view of what the zoom is showing in the browser window.</td>
</tr>
<tr>
<td>Save selection only</td>
<td>If a rectangle had been drawn across the image, this option would be available to save only what is selected.</td>
</tr>
</tbody>
</table>

Table 7. Save checkboxes of the HDR image window (these can be selected in combination)

Only after an image has been saved can it be added to a catalog. If you select to add image to catalog via File → Add to catalog, you will be prompted to save the image first.

**HDR error messages and what do they mean**

The following are the possible error messages when running the Make HDR command. something needed here.  

![Figure 44. HDR error message – camera response error message](image-url)
Images taken more than 30 minutes apart cannot be combined into HDR images. To bypass this built-in safeguard, goto Set → Date command and modify the dates of the images.

![HDR error message](image)

**Figure 45. HDR error message – image capture times too far apart**

Images taken by different cameras or those with different resolutions also cannot be combined into an HDR image, see Figure 46.

![HDR error message](image)

**Figure 46. HDR error message – images from different cameras or of varying resolution.**

**How to shoot bracketed images (taken from the Photosphere Quickstart) – “raw” images not recommended**

It is best if you take a series of 10 or more exposures of an interior scene looking out a window and containing some large, smooth gradients both inside and outside, to determine the camera’s natural response function. Be sure to fix the camera white balance so it does not change, and use aperture-priority or manual exposure mode to ensure that only the speed is changing from one exposure to the next. For calibration, you should place your camera on a tripod, and use a small aperture (high f-number) to minimize vignetting. Take your exposure series starting from the longest shutter time and working to the shortest in one-stop increments.

Once you have created your image series, load it into Photosphere directly. Do not process with other programs (e.g. Photoshop) unless the images were “raw”, in which case they would need to be converted into TIFF or JPEG format before Photosphere can work with them.

Shooting in raw format offers no tangible benefits and you are just making more work for yourself.

**Making a panorama**

refer to tutorial.

**Red-eye removal**

To remove red eyes in images, draw a box around the eyes and click on the <Apply> button and then select “RedEye”. Whenever possible, enclose the whites of the eyes since those pixels help
the command determine where and which redish pixels are part of the red eye. The box disappears after the red-eye has been removed, see Figure 47 and \textbf{Error! Reference source not found.}.

If the box is drawn too big (takes up too much area on the image), then the “RedEye” option may be unavailable. Alternatively, you can try the command on one eye at a time.

![Figure 47. Image with red-eye (left), and red-eye removed (right)](image)

To undo red-eye removal, either goto <Apply> and select “Undo RedEye”, or Edit → Undo…. To save the changes, goto File → Save As..., and check the boxes for “Apply orientation & cropping” and “Apply zoom (resample).” (refer to export section? xxxxx)

**Exposure Adjustment (SpotMeter)**

The SpotMeter command can be used to adjust the exposure of a displayed HDR image (does not work for LDR images). This is a useful command if there are areas of the image which contain details but they are not readily visible. To use the command, draw a box around an area of interest and then click on the <Apply> and select the SpotMeter command. The image will re-expose itself based upon the average luminance of the selected area, see Figure 48 and Figure 49.

The SpotMeter command can be used in combination with the “Auto”, “Local”, and “Human” commands (but I don’t know how to describe this).

![Figure 48. SpotMeter applied to dark shade trees.](image)
Figure 49. SpotMeter applied to bright windows.

Image Analysis...
Tutorial -- How to Make a Panorama

Photosphere can make horizontal and vertical panoramas. This tutorial will show how to construct a horizontal panorama. The process for making a vertical panorama is the same.

Input images needed for panorama

To stitch together a panorama, first choose a set of images/thumbnails and then double click to bring them up the image browser. There must be at least one overlapping, salient feature for neighboring images. Figure 50 below shows the features (boxed and lettered “a” through “e”) that will be used for creating the panorama (match a-a, b-b, c-c, etc).

When possible, select features that are close to the horizon. Because the seam of the panorama originates from the matching feature outwards and mis-matching errors increase the farther they are from the seam, a matching feature that is near the bottom or top edge of the image (assuming you are making a horizontal panorama) may cause the panorama to show more errors.

In the following example, features with high contrast from their neighboring pixels were selected, along with features that were easy to track from image to image (indistinguishable bumps in the landscape near the horizon were not selected).
Figure 50. Six thumbnails and their features selected for the panorama command.

In the first (left most) image, click and drag a small box over a salient feature that is also visible in the second (adjacent) image, see Figure 51. In this example, a small corner of the tree has been selected as the feature to be worked on since it is fairly distinct in both images.

The <Apply> button becomes active after a box has been drawn on the first image (the box is drawn with gray in Photosphere; red is only used here in the documentation for contrast). Click on the <Apply> button and select <Pano Orig> to let the program know you are starting to build the panorama.

Note that if you do not see <Pano Orig> at this point, then it means that the box is too big and you need to draw a smaller box.

Advance to the neighboring image (by using the arrow button) and draw a box around the same feature like before. Click on <Apply> again and this time select the <Pano Dest> option. Again, if
the box you have drawn is too big, then the <Pano Dest> option will be unavailable and you will need to draw a smaller box. The box will disappear from the image after a few moments of calculation and the two images will be linked.

(It is possible to goto File → Make Panorama to see the combined results up to this point or keep going until all images are put together).

Next, repeat as before.

Draw a box around another feature that lies within the second image as the origin and mark that as the <Pano Orig>. Then advance one more image and assign the corresponding feature as <Pano Dest>. The box will disappear once the images have been linked.

**Figure 51.** First two images of the panorama. “Pano Orig” left and “Pano Dest” right.

**Figure 52.** 2nd and 3rd images of the panorama. “Pano Orig” left and “Pano Dest” right.

Repeat this process as many times as needed to create the panorama.

If you make a mistake or want to start over, select the “Clear Pano” option under the <Apply> button. In addition, when stitching together multiple panarams within one Photopshere session, be sure to “Clear Pano” after each panorama (so the subsequent ones do not end up extra information added to them from the earlier ones).
You can scale down the panorama by using the “Output Image Resolution” option. Since it is faster to create a smaller image, it may make sense to build the first attempt (or attempts) at a smaller size so you can obtain a quick preview to check the work. The matte colors combined with the Expand, Trim, and Fill options can be used to finish off the borders of the images. Refer to table and images below. Alternatively, you can crop the panorama after it is created.

When you are satisfied with the panorama settings, a full sized version can be created by moving the “Output Image Resolution” slider to “Full”.

If you are unsatisfied with the panorama and want to start over, click on the <Apply> button and select <Clear Pano>.

If you want to add new images (make the panorama even wider), added existing links via the <Apply> menu, or start over by selecting “Clear Pano” or pressing the “Clear” button in the “Make Panorama” dialog.

<table>
<thead>
<tr>
<th>Matte Color (black used as examples)</th>
<th>Expand</th>
<th>Trim</th>
<th>Fill</th>
<th>Example</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td>Figure 54</td>
<td>Average is the average color of all of the pixels in the scene.</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td>Figure 55</td>
<td>Compliment 1 and 2 refer to the colors that are 120 degrees away in either direction from the average color of the image as compared from the color wheel.</td>
</tr>
</tbody>
</table>
Matte Color
(average used as example)

Table 8. Combination of Matte color and options.

Figure 54. Black matte only

Figure 55. Black matte + Expand

Figure 56. Black matte + Trim

Figure 57. Black matte + Expand + Trim

Figure 58. Black matte + Expand + Fill

Figure 59. Black matte + Expand + Trim + Fill

Figure 60 Fill by itself should only be used with average.

Figure 61
When you are satisfied with the panorama, go to File → Save As… to save the file. The panorama is not automatically saved or added to your catalog. For information on the save options, see xxxxx.

It is also possible to make HDR panoramas, make the HDR images first and then make the panorama.

It may take a few tries before you get used to the idea of selecting image features, and some features definitely work better than others. It's best to select a corner or prominence with high contrast. Busy areas make for poor feature matching, which can cause misalignment in the results. Trees and mountain peaks are good features. Fields of grass and waves on water are not. Keep camera settings constant between frames. Photosphere can take both HDR and LDR images as input for making panoramas, but not in combination.